CategoryFilter no longer showing all values

Comments

3 comments

  • Avatar
    Randolph Abelardo

    Hi @Bob.

    I'm assuming that the root cause of your problem is the pertinent column(s) containing mixed data-types

    AwesomeTable (AT) displays whatever is given to it. So, we need to make sure that we're feeding it with the correct data-type and formatting. Also, AT applies the appropriate data-formatting type to the column based on the available data. If it detects mixed-data types, AT selects whatever Google Sheets assigned as a default. To remedy this, you need to force the pertinent column to be formatted appropriately (plain text in your case - screenshot below). Then refresh your AT view to reflect the changes.

    If this doesn't resolve your issue, please share your:

    AwesomeTable link - Share with us your AwesomeTable & Google Sheets datasource so we can pinpoint where the problem is and provide the right solution at the soonest possible time. Detailed instructions here.

    Google Sheets datasource - It's best to set the sharing settings to Anyone with the link. Click here to learn more.

    You can opt to anonymize your content by using *dummy data* (fake, but realistic) if your Sheets contains confidential info.


    - Randy

     

    0
    Comment actions Permalink
  • Avatar
    Bob Podevijn

    Hi Randy

    Thanks for your answer. That was exactly what I already tried several times without succes. The issue was not related to the formatting.

    Found what was causing it. I filled the data by use of a formula in the first cell, thus sorting in copying it from a different sheet. Seems AT can't handle such data? When I copy the sorted values "only" to a new sheet using a function in script editor, and use that new data sheet with AT, it all works fine.

    It is a workaround that seems to work for me.

    Kind regards.
    Bob

    0
    Comment actions Permalink
  • Avatar
    Randolph Abelardo

    Glad that you were able to find a workaround, @Bob.

    0
    Comment actions Permalink

Please sign in to leave a comment.