dateFilter...displays to wide of a range?

Comments

5 comments

  • Avatar
    Randolph Abelardo

    A very compelling shocked emoji, @Deadra :D

    AwesomeTable (AT) displays whatever is given to it. So, we need to make sure that we're feeding it with the correct data-type and formatting. Also, AT applies the appropriate data-formatting type to the column based on the available data. If it detects mixed-data types, AT selects whatever Google Sheets assigned as a default (I reckon this is what happened in your case).

    To remedy this, you need to force the pertinent column to be formatted as either Automatic or Numeric (with the correct date style). Then refresh your AT view.

    Hope this helps.


    - Randy

  • Avatar
    Deadra Kolker

    Hmm, tried setting it to automatic, plain text, and even date that displays mm/dd/yyyy in google sheets just like the format set in the formatting in Awesome Tables. The best it did was going from 00/31/1969 to 00/31/1969....

     

    So it went from too much range to NO range....

     

    I did notice when I change google sheets to automatic, instead of the numbers reading "07/17/2016" the date read as "42565". Not sure what that's about.

  • Avatar
    Randolph Abelardo

    Please share your:

    AwesomeTable link
    Share with us your AwesomeTable & Google Sheets datasource so we can pinpoint where the problem is and provide the right solution at the soonest possible time. Detailed instructions here.

    Google Sheets datasource
    It's best to set the sharing settings to Anyone with the link. Click here to learn more.

    You can opt to anonymize your content by using dummy data (fake, but realistic) if your Sheets contains confidential info.

    - Randy

  • Avatar
    Randolph Abelardo

    Thanks for sharing the relevant files, @Deadra.

    As suspected (see Fig. 1), the underlying data-type for column G (Purchase date) is not appropriate (plain text) for the dateFilter. More about this here. To remedy this, properly convert column G to a date format or use a separate column for this.

    Note: Please avoid blank entries (see Fig. 2) as Google Sheets will automatically assign values here. This automatic conversion also happens in MS Excel.

    Here's the rectified version of the view. Simply click the USE TEMPLATE button to create your own copy,

    Hope this clarifies everything.


    - Randy

     

     

    Fig. 1

     

     

    Fig. 2

     

Please sign in to leave a comment.