Deleting records

Comments

2 comments

  • Avatar
    Randolph Abelardo

    Hi @Becky.

    If you're using Google Forms to add and/or remove records, please read this related FAQ.


    Deleted form entries in Google Forms still shows in my view.

    I already deleted individual answers from Google Forms' Response tab. But I'm still seeing the deleted entries in AwesomeTable. What did I miss?

    This is a Google Forms expected behavior. The Google Forms to Google Sheets - Form Response synchronization only works when new entries are added. However, if you delete individual or all responses in Google Forms, the changes won't be reflected in the linked Google Sheets datasource. Click here to learn more.

    To bypass this Google Forms limitation, you could either:

    • Manually delete the pertinent entries in Google Sheets or
    • Unlink > re-link to an existing Form Response sheet destination. Then reload your map view.


    Note
    : If you follow the second option, make sure that the most recent Google Sheets tab is the current one selected as the datasource within the AwesomeTable editor. Otherwise, you'll still see the previous version with the un-deleted entries.

    Hope this helps.


    - Randy 

    0
    Comment actions Permalink
  • Avatar
    Brandon Carraway

    Hello, I can think of two options:

    1.A) Create an entry for the 'Status' of the item(s) and use Query Filtering. 

    IE) Active, Inactive

    Following this method, you can follow this guide to setup default filter views to only show "Active" items by default. 

     

    1.B) Create an entry for the 'Status' of the item(s) and use Display Filtering.

    Same as above, but now the user selects a filter criteria for "Active", and shows all items by default.

     

    2) Manually delete the line from the Google Sheet.

     

    --Hope this helps!

    0
    Comment actions Permalink

Please sign in to leave a comment.