Comments

5 comments

  • Avatar
    Nicolas Gauvin

    Hello,

    There is no maximum number of rows in Awesome Table. However if too many data are being loaded it can slow down the loading so much that your browser will make Awesome Table crash.

    Does your Awesome Table view workif you only add 1000 entries?

    Nicolas

  • Avatar
    Randolph Abelardo

    Hi @Clicksin Site,

    1.) Are you still experiencing the same issue?
    I was able to access your site.
    Please note your view currently houses 28,757 rows of data (see image below).
    This will take some time to load - even longer for those with slower connections.
    I've reloaded this many times, though it took a while, I never experienced your issue where it said Error: No data to display.
    I also ran some pageLoad tests using India-servers and the median time it takes to load your specified page is between 9 - 11 seconds.

    A. May we know what your current download speed is?
    B. Have you tested this on another device and / or faster network?

    Recommendations:

    I would also like to invite you to read more about using the recommended pagination settings

    Since you have lots of records, we recommend using pagination to optimize your Table view. You can do this by specifying smaller values (e.g., 10 or 20) in the # of items displayed field.

    Pagination improves your Table view functionality by:

    • Preventing browser-overload and decreasing the load-time.
    • Not requiring your users to scroll down to see the entire table.
    • Displaying tens of thousands of results smoothly - without issues.
    • Allowing your viewers to leverage filters and find an item at a glance instead of getting lost in a mass of data.

     

    2.) As for the maximum rows in Google Sheets, I agree with @Nicolas. Google Sheets can support up to 5 million cells (the number of rows is dependent on the number of columns you have). 

    Hope this helps.

     

    - Randy

     

  • Avatar
    Rehne Gibb Larena

    Hi Randy,

    I am having a similar situation. I have a table with thousands of rows (60K). I tried your pagination recommendation but it still loads very slow.

    It seems that the table is loaded one time. I think it is not a pagination function in its truest sense. The table should only load the first # of items to be displayed so that it loads fast.

  • Avatar
    Randolph Abelardo

    Hi @Rehne. 

    Please create a separate post. Include your reply to the questions below:

    1.) Besides having 60k rows of data, what other contents are included or referenced in your datasource (images, external links)?

    2.) How long does your Awesome Table view take to load?

    3.) Where is your Awesome Table view embedded (what CMS or website builder)?
    Please share this link (if embedded).

     

    Also, please share your:

    AwesomeTable link
    Share with us your AwesomeTable & Google Sheets datasource so we can pinpoint where the problem is and provide the right solution at the soonest possible time. Detailed instructions here.

    Google Sheets datasource
    It's best to set the sharing settings to Anyone with the link. Click here to learn more.

    * You can opt to anonymize your content by using *dummy data* (fake, but realistic) if your Sheets contains confidential info.

     

    - Randy

  • Avatar
    Rehne Gibb Larena

    Hi Randy,

    Thank you very much for the response. I created a new post as per your instruction:

    https://support.awesome-table.com/hc/en-us/community/posts/360004189660-Table-with-60K-rows-loading-very-slow

    Again, thank you very much.

Please sign in to leave a comment.